Skip to main content

TP-Link Archer C7 V2 - OpenWrt - Barrier Breaker

Was looking for the best AC wifi router to replace my Buffalo WHR-G300NH and found that TP-Link has just released an Archer C7 V2 which has wifi card supported by ath10k driver based on the information found here.

Here is the packaging, it says that it supports Unifi & Maxis Fiber but the support is not out of the box. You need to ask the seller a beta firmware which has VLAN support but I couldn't get mine working using even the beta firmware on my Maxis Fiber. Emailed TP-Link support but got a reply saying that they don't have Unifi/Maxis Fiber ready firmware and asked if I want to swap with one that already have, but nah, I bought the router not for running the stock firmware anyway.



Ver 2.0 hardware as per the sticker.

Anyway, I waited for a week or so and someone came up with the new hardware profile which creates the correct firmware image for OpenWrt. If you've this new V2.0 hardware and wanted to run OpenWrt on it but couldn't wait to get the patches into the trunk, check this patches:


To build your own OpenWrt firmware for this ver 2.0 hardware, followed these steps:

1. Have Debian 6.0 or any development system which could cross-compile the OpenWrt firmware. There are many guides available on the net, but for me, I've a VMWare Debian 6.0 VM ready on my Hackintosh machine. 
2. Follow the guide found in: http://wiki.openwrt.org/doc/howto/obtain.firmware.generate. Follow the steps to get the trunk, untar the file and apply the above patches.
3. To generate the image, I was using the following command, I need the ath10k and luci support in the image:
$ make image PROFILE=ARCHERC7V2 PACKAGES="ath10k luci"
4. The generated image ready to be flashed can be found in the bin/ar7xxx/ as openwrt-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

UPDATE: The profile has been updated into the mainstream trunk distribution and the trunk now contains the image for Archer C7 V2.0. The image can be downloaded here:

http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

1-4: Do not forget that the trunk images do not contain LUCI, so, you may need to login into your router using ssh or telnet. Get it to the net and install LUCI using command line or, if you want to, you could follow the step 1-4 above, have you own image rebuild with the necessary LUCI packages.

UPDATE: The latest Barrier Breaker RC3 can be downloaded now. This has the fixes for 5GHz band which includes the calibrated setting etc. I've tested this with multi devices that support the 5GHz band and they work just fine. Please head up here to download the latest image:

http://downloads.openwrt.org/barrier_breaker/14.07-rc3/ar71xx/generic/openwrt-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

LATEST UPDATE: Barrier Breaker has been available for many months now, so, please download it from the official website. Please read the comments left by visitors, they may contain important information that is helpful to make full use of the features available for this router.

5. Go and flash the firmware, do remember, the default IP address for OpenWrt router is 192.168.1.1.



To get Maxis Fiber to run, just go to network->vlan and have the following, surely don't forget to set the PPPOE userid and password:


That should be it.

Comments

Mark Swift said…
Hello, I have this running on my Archer V2 but am not seeing an option to enable 5ghz? Any ideas?
9M2TPT said…
Hi Mark, you need to check if you've kmod-ath10k installed.
Vincent Murphy said…
This is the only documented confirmation that v2 has a built-in profile, so thank you for doing that.

Where did you buy your v2 model in the UK? I'd live to avoid having to return a v1.
9M2TPT said…
Hi Vincent, I'm not in UK and I've no idea where you could get the latest V2 from. Best is to visit your local PCWorld or Currys, they might have it and you could check the box.
Mark Swift said…
Well, I tried the OpenWRT branch but reverted back to stock, too many issues for me. Firstly my MBP could not connect to the 5GHz channel in N / AC mode. Secondly I found the throughput much reduced compared to stock. I hope the compatibility improves.
Anonymous said…
In fact Archer C7 v2 doesn't work neither Openwrt nor DD-WRT. All these posts are misleading. Even in cases with uncalibrated driver 5Gz radio starts connecting, in fact no AC link. Poor performance and stock firmware is much better. But Archer works well with compex cards....
Unknown said…
PC World/Currys do not stock this model in-store as I tried this method myself.

I were however able to order it online to the local store so I could check the box and not have to worry about posting it back if it was a v1. Picked it up today and it IS a v2 though so it might be worth just ordering it straight for home delivery.
Anonymous said…
Where do you bought it ?
I tried on Amazon.fr bu get the old and unasable v1.1 hardware.
9M2TPT said…
The latest trunk and RC2 has this fixed.
9M2TPT said…
I bought my locally here in Malaysia. Many has tried Amazon and failed. So, best is to head up to your local store.
Brent said…
The default firmware build of OpenWRT doesn't have luci installed and no password set for root user, which disables SSH access. Do you have a way to access the router for installing packages and changing settings other than the web UI and SSH? I'd love to avoid having to crack it open and connect my serial adapter after doing a factory reset...
Brent said…
Ah ... found it. telnet on a LAN port.
Anonymous said…
Also don't forget to make sure the wifi switch in the back is set to "on"...
My brother had been looking at the router before I flashed it... and flipped the switch, turns out it only turns off the 5Ghz(as far as openwrt goes) and cost me about an hour of flashing a few times until I caught that.
Anonymous said…
Hi 9M2TPT! Found your blog when I was looking a router replacement also for my 9yo WRT54G. Have been using Tomato but the options are very expensive (e.g. ASUS) when compared to the Archer C7. Is it still working fine with OpenWRT? I mainly need the QOS and bandwidth limiting features....do you know if these work well on OpenWRT?

Thanks!
9M2TPT said…
Haven't play around with QOS on OpenWRT, so I couldn't say much about it. There is another firmware which is based on OpenWRT called Gargoyle but it seems that they do not have Barrier Breaker support yet.
9M2TPT said…
According to the following link, gargoyle will support BB eventually.

http://www.gargoyle-router.com/phpbb/viewtopic.php?f=3&t=6082#p24898
Mike said…
Thanks for the reply 9M2TPT - that was me above. Would you still recommend this router for general use with OpenWRT? All OK for you so far? I'm seriously leaning towards it if there are no further issues.
9M2TPT said…
Hi Mike, I've no problem with my day-to-day use of the router with OpenWRT RC3. I've used both band interchangeably between my devices and both bands work okay. I haven't done any throughput test on any of the band though but the ath10k support seems to be stable now.
Mike said…
Great, I'm convinced! Though there is a newer Archer C8 on the way using Broadcom (Tomato!)...hmm decisions decisions.
Bryan Bai said…
How were you able to revert back to stock? Did you have to remove the bootloader from the stock firmware image? I read that on a forum, but I have no idea how to do that.
Jalil said…
Salam 9M2TPT,

Can you help me how to set up the PPPOE using the OpenWRT firmware.

The menu was quite confusing and I am not sure how to set it up.

Thanks.

9M2TPT said…
What ISP do you have? Should be straight forward thing if you know your ISP account's username and password. Nothing much to setup except if you're using MAXIS or UNIFI fibre where you need to setup a VLAN correctly on your router.
Jalil said…
I'm using the Maxis fibre, the username and its password is fully known to me.

I have flashed the OpenWRT Breaking Barrier and the VLAN setting was setup as per the screenshot as given.

The Luci menu layout was quite confusing and I have setup the PPPoE setting using command line through the ssh connection, however the internet is still not available.

Tomorrow maybe I will post some screenshot if you can help me and probably others who have bought this router.

Thanks for your prompt reply.
9M2TPT said…
If you've account in lowyat forum, do post your problem there and we'll discuss further there, much easier than using this blog.
martianxo said…
Hi 9M2TPT. Can you check whether openwrt allows setting VLAN ID=10 on the WAN port of the C7? I am considering getting the C7 but it only allows VIDs > 16 on stock firmware.
9M2TPT said…
Hi, yes, you can use VLAN ID > 16. My ISP uses VLANID 621 and it works with OpenWRT.
martianxo said…
Thanks for your fast reply. I am looking to set VLAN ID=10. Could you check if that is possible?
9M2TPT said…
I can set it to VLANID=10 but I've no mean of testing it since it will break my WAN connection. Here is part of my /etc/config/network:

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '621'
option ports '1t 6t'
9M2TPT said…
In original blog, I did mentioned that VLAN tagging wasn't supported on the stock firmware. I haven't check the latest stock firmware if it does now.
martianxo said…
Alright. Thanks for checking. The stock FW for hardware version V3 as shown on TP-LINK's emulator page does seem to support VLANs, but does not allow VID < 16. I might just pick one up if I can get one for cheap.
Anonymous said…
hi 9M2TPT

i have this ac1750 v2 and i use streamyx
can openwrt support streamyx setting?
9M2TPT said…
Sure, why not? But you need to have it connected to your ADSL modem.
Anonymous said…
ok thanks bro!
ya but i use my old modem/router act as modem only using bridge mode
is really good if i use openwrt firmware on this router?
i afraid that i might brick it
is my first time act

hope you can help me about this
9M2TPT said…
I've reason why I need to go with openwrt, if your need already available on the stock firmware, might as well stick with it. Anyway, make sure you got the correct file when uploading to avoid bricking it. It is easy really.
victorcoder said…
Thanks for this post, it served well as orientation but the current OpenWrt version Breaking Barrier (no RC) supports Archer C7 v2 almost 100%

Just for the record:

Almost everything could be configured from the new bootstrap based UI

ath10k driver doesn't report well wifi AC Rx/Tx rates and LuCI has no support for displaying well the ac type thus the ac speed is not as stock firmware.

To workarround this, set wlan0 (wifi AC) to VHT80 (80Mhz):

$ uci show wireless
$ uci set wireless.radio0.htmode=VHT80
$ uci commit wireless
$ wifi

This should give you wifi AC full speed.

NOTE: If you change wlan0 config from the UI you'll have to redo this fix.

Also wifi leds doesn't work based on https://dev.openwrt.org/ticket/18188

You can workaround this from the web UI, just pick the led combination you prefer.

I picked WLAN2G: phy0tx WLAN5G: phy1tpt
9M2TPT said…
Thanks for the lead.
martianxo said…
Received my archer c7 v2 this morning in the mail and had it running on singnet's fibre service with openwrt 14.07 within an hour. For other's reference, here are the relevant VLAN settings from /etc/config/network.

config interface 'wan'
option proto 'dhcp'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option ifname 'eth0.10'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 2 3 4 5'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '1t 6t'
option vid '10'
Anonymous said…
To enable 5ghz:

uci set wireless.radio0.htmode=VHT80
uci commit
wifi
Anonymous said…
I always have issues with clients connect to the 5 GHz radio. Connectivity is slow/broken. Clients on the 2.4 GHz band have no such issue. Does your workaround fix this at all?

Popular posts from this blog

Configuring TechniColor TG784N V3 (Maxis issued broadband router) to use different DNS servers

Previous write up deleted. It seems to change the DNS servers in as shown on the status, but it does not really work.

Check the following website, this seems to work:

http://www.o2help.co.uk/router-change-dns/

This can be done from the WEB GUI too, go into the following configuration path:


In my example above, I'm using paid service unblock-us instead of google public DNS servers.

Raspberry Pi + svxlink = Low power echolink node

What is the easiest way to get echolink node up and running on raspberry pi? Surely, get a premade image which has everything inside. I've created one image which can fit into 2GB SD card for this, just follow the following steps to get it up and running:

For hardware, you need to have the following:
Raspberry Pi for sure, with a minimum 4GB SD cardA USB echolink interface, can be commercially sourced or DIY. There are many DIY schematics out there that you could follow.  Here is the configuration on how to get the things working together, courtesy of svxlink.de website:

For software:
Download the following prepared image from google drive, it is based on raspbian-2015-02-16 image and has pre-installed svxlink-14.08. raspi-wheezy-svxlink.img.zipUnzip the file and copy it to your SD card using the following instructions that can be found here.Boot up the RasPi, if you do not have an HDMI monitor, you may want to access the RasPi from your terminal emulator (putty or the like), connec…

Debugging DMEE

I've come across many posting on the Internet (via google search), people asking on how to debug a DMEE for payment program. One of the few suggestion was to create a user exit just before the node that we would like to debug and put our breakpoint there. It seems that SAP has built-in this feature without needing us to create a user exit (available in ECC 6, have no idea if this is available on prior releases). Here is how you can put your breakpoint without any coding.

1. Display your DMEE tree using transaction: DMEE_DEBUG.


2. Click on the node that you would like to debug.
3. Go to conditions tab, you could see the Set Breakpoint button. Click to set.



4. Run the SAPFPAYM and specified the payment run date/id, payment format etc. SAP will stop at the node which you point your breakpoint at, as in 2.
5. To remove your breakpoint, just run the DMEE_DEBUG again, there is an option to delete all own breakpoints or all.